A PHP Error was encountered

Severity: 8192

Message: mysql_escape_string(): This function is deprecated; use mysql_real_escape_string() instead.

Filename: mysql/mysql_driver.php

Line Number: 319

1с Бухгалтерия Беларусь 1.6 - переход на IBAN

1с Бухгалтерия Беларусь 1.6 - переход на IBAN


Рубрика: Полезности -> Программирование (WEB) -> Администрирование
Метки: | |
Просмотров: 1801

И так, ниже подробная инструкция как перейти на новый формат счетов IBAN в Бухгалтерии для Беларусь версии 1.6

Как перейти на IBAN в Бухгалтерии Беларуси 1.6?

1. Обновляемся до последней версии 1.6.73.24

2. Проверить на всякий случай, чтобы в справочнике валюты код белорусского рубля был 933.

3. Необходимо отредактировать в конфигураторе стандартную обработку "Переход на формат IBAN"

Найти часть обработки Процедура КнопкаУстановитьБИКSwiftНажатие(Элемент)

Полностью удалить и заменить текстом:

Процедура КнопкаУстановитьБИКSwiftНажатие(Элемент)
    
    Таб = Новый ТабличныйДокумент;
    Макет    = ПолучитьМакет("БИК_SWIFT");
    Секция2    = Макет.ПолучитьОбласть("Секция_2");
    Таб.Вывести(Секция2);
    
    ТаблицаКодов = Новый ТаблицаЗначений;
    ТаблицаКодов.Колонки.Добавить("Код");
    ТаблицаКодов.Колонки.Добавить("КодН");
    
    Для Инд=1 По Таб.ВысотаТаблицы Цикл
        Код    = СокрЛП(Таб.Область(Инд,2).Текст);
        КодН= СокрЛП(Таб.Область(Инд,5).Текст);
        Если ПустаяСтрока(КодН) Тогда
            Продолжить;
        КонецЕсли;
        
        СтрокаТаблицаКодов = ТаблицаКодов.Найти(СокрЛП(Код),"Код");
        Если СтрокаТаблицаКодов=Неопределено Тогда
            СтрокаТаблицаКодов = ТаблицаКодов.Добавить();
            СтрокаТаблицаКодов.Код    = Код;
            СтрокаТаблицаКодов.КодН    = КодН;
        КонецЕсли;    
        
    КонецЦикла;
    
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
                   |    Банки.Ссылка,
                   |    Банки.Код,
                   |    Банки.Наименование,
                   |    Банки.БИКSWIFT
                   |ИЗ
                   |    Справочник.Банки КАК Банки
                   |ГДЕ
                   |    Банки.ЭтоГруппа = ЛОЖЬ
                   |    И НЕ Банки.ИспользоватьФорматIBAN = ИСТИНА";
    Выборка = Запрос.Выполнить().Выбрать();
    
    ОбработаноОбъектов = 0;
    Пока Выборка.Следующий() Цикл
        СтрокаТаблицаКодов = ТаблицаКодов.Найти(СокрЛП(Выборка.Код),"Код");
        Если СтрокаТаблицаКодов=Неопределено Тогда
            Продолжить;
        КонецЕсли;    
        Если СокрЛП(Выборка.БИКSWIFT)=СокрЛП(СтрокаТаблицаКодов.КодН) Тогда
            Продолжить;
        КонецЕсли;    
        ОбъектБанк = Выборка.Ссылка.ПолучитьОбъект();
        ОбъектБанк.БИКSWIFT = СокрЛП(СтрокаТаблицаКодов.КодН);
        Попытка
            ОбъектБанк.Записать();
            ОбработаноОбъектов = ОбработаноОбъектов+1;
        Исключение
            Сообщение = Новый СообщениеПользователю();
            Сообщение.Текст = "Не удалось записать элемент <"+Выборка.Код+"> <"+Выборка.Наименование+">";
            Сообщение.Сообщить();
        КонецПопытки;    
            
    КонецЦикла;
    
    Сообщение = Новый СообщениеПользователю();
    Сообщение.Текст = "Обработано банков: "+ОбработаноОбъектов;
    Сообщение.Сообщить();
      
 КонецПроцедуры

4. Обязательно перегружаем 1с

5. Запускаем обработку, которая идет в комплекте и которую уже подредактировали (Операции - Регламентные - Переход на формат IBAN) и нажать на кнопку "Заполнить БИК SWIFT банков". Данная операция должна автоматически заполнить БИК банков в вашем справочнике банков на новые. Открыть справочник банки и убедиться, что в колонке БИК SWIFT записан старый код, а в колонке БИК до 04.07.17 новый код.

Если это не так, то в стандартной обработке нажать на "Переключиться на использование БИК". Т.е. смысл в том, чтобы привести справочники в состояние до формата IBAN.

6. Также убедиться, что справочник счетов не переведен в новый формат. Если не так, то в стандартной обработке нажать на "Переключиться на использование формата до IBAN". В справочнике "Банковские счета" в колонке "Номер счета" должен быть старый счет, в колонке "Номер счета до 04.07.2017" либо пусто, либо счет в новом формате, если вы записывали его ручками.

7. Когда справочник банки будет корректно заполнен, то запускаем внешнюю обработку скачанную отсюда yadi.sk 10 .

8. Выбираем каталог для выгрузки и нажимаем кнопку "Выгрузить". Должен появиться файл csv c тремя колонками: код банка в старом формате, код валюты, номер счета в старом формате. Если в этом файле что-то не так, то проверяем справочники Банки и Банковские счета как описано выше.

9.Далее полученный файл прогоняем через пакетный калькулятор на сайте НБ iban.bisc.by 7 и получаем ответный с новыми кодами банка и новыми счетами.

10. Выбираем полученный файл в обработке и нажимаем "Загрузить".

11. На этом этапе табличная часть в обработке должна заполниться полностью и важно, чтобы колонка "Р/сч ссылка" также подхватилась.

11. В обработке нажимаем "Выполнить переход на IBAN" и справочник счетов заполнится новыми счетами.

12. В стандартной обработке нажимаем поочередно кнопки "Переключиться на использование формата IBAN" и "Переключиться на использование БИК SWIFT".

Большая часть инструкции взята с форума forum.ru-board.com 12 и написана там частично пользователем smomel

Автор: BuxarNET (Тяшкевич Виталий) для LinuxMir.ru , написано по личному опыту.